How to enable BMW ICOM A2 to work with ISTA-P 3.59?


 
You need to have a valid ICOM A2 license or ISTA-P loader, to enable the BMW ICOM A2 firmware to work well with ISTA P v3.59;

That is,

ICOM A2 requires valid firmware license. 

If you have no license, just update firmware to latest version and use ista-p loader v4.9 (v5.x discontinued).



Free download 

ISTA P Loader (for those with ista p but data is gone)
 
https://mega.nz/#!fhkXySwJ!heZSdusfCDZ8lno5_rpEZYSSS3MYC73JhZPCkyh6lQ0 
ISTA-P 3.59.0.600 (tested OK, with Loader v4.9)

https://www.Gm-Tech2.com/wholesale/v20167-bmw-icom-software-windows-7.html



User feedback on ISTA/P and loader
More info on ISTA P loader:

Tried running Rheingold ISTA/P 3.55.0.100 using v3.2 loaded.
Select K+Dcan emulator, which started fine. (network tool for kdcan is necessary)
Select BMW car and ista/p loaded up.
Start new session. Fine.
Select my machine.
Select interface. all good so far.
On the next page I had a progress bar on the bottom left.
First job finished, then it said "Determining Vehicle Identification number"
Then things stopped and I got an error box come up saying:
"An error on execution of the measure.
94201 Technical service initialisation failed.
10007 (CIP)- Error during initialisation of EDIABAS."
All help appreciated as this is getting frustrating.

Then run the network config tool for k+dcan:
https://mega.co.nz/#!n5hmSSLS!VPWI77otjCryNmqf8IGwZsPlaBGz0T5fuiHN2TUZEPU 


Error solved. And ISTA/P works like a charm.



Tip: What to do if programming data is missing?

"Programming data" in launcher is for ISTA 4 only (I, F & G series). Requires separate install to ISTA/P.