VXDIAG VCX SE Benz VCI Cannot be Used Solution


Here’s the working solution to VXDIAG VCX SE for Benz 2020.12 version Xentry “VCI Cannot be Used” error.

Problem goes like this:
Hook up vcx se Benz and 2012.12 version xentry, update both VCI and DoIP firmware no problem.
No communication. Reports error VCI cannot be used and xentry shows multiplier initialization failed
Vxdiag Benz 2020 12 Vci Firmware 1
Vxdiag Benz 2020 12 Vci Firmware 2
Vxdiag Benz 2020 12 Vci Firmware 3
Vxdiag Benz 2020 12 Vci Firmware 4
Vxdiag Benz 2020 12 Vci Firmware 5

Gm-Tech2.com solution:
Download the vcx se benz DoIP firmware update patch here.
Put it on desktop. Connect device to laptop, run the update patch.

After finish install patch, reinstall Benz C6 driver from “Diagnostic” menu on vx manager.

Then click “Firmware” to update firmware again.